Moodle 3.2 or later requires at least PHP 5.6.5 (currently using version 5.4.45-0+deb7u11). Some servers may have multiple PHP versions installed, are you using the correct executable?